Preachit 4.1 is here

We're really excited to announce today the release of Preachit 4.1 stable as well as compatible versions of our templates and extensions. Preachit 4.1 marks a real move forward in flexibility and power while maintaining the simplicity of the component.

This version of Preachit is the quickest and most powerful version yet. There are some cool added features such as the ability to write ID3 tags and fuller integration with Amazon S3 around the world. There are also some styling differences. However, the main changes are under the hood in opening up the power of the Preachit engine to developers of templates and other extensions that want to harness the sermon data held in Preachit.

New API

Preachit 4.1 has a new api that can be accessed from inside and outside of the component. With a couple of lines of code you can be linked into the full power of the Preachit engine and pull out all the details without having to write any sql queries. This should give greater scope for developers who want to develop other extensions with access to Preachit data. It also allows us to write more complicated functions for getting specific details without slowing down the programme.

The new version also has a new template api. This brings together the code we've developed for our templates and make them accessible to anyone who wants to develop their own template so that they can bring the various elements in with a simple api call.

Preachit 4.1 also contains the JSON api that we've been developing over the last few months in Preachit 4.0. This gives developers the option of grabbing Preachit data easily and simply from applications outside of your Joomla site - such as church apps.

For more details on this please check out our developers doc page.

New DOCS

Alongside Preachit 4.1 we are revamping our docs page for Preachit. These will include a refresh and expansion of our video tutorials for the various tasks involved in using Preachit. It also include a developers area where we will give guidance in using the API's and harnessing the power of the Preachit engine.

Updating

For details on updating to the new version please check out our update page. You will need to update any templates and other extensions to Preachit 4.1 compatible versions if you want to use the new component.

3rd Party Extensions

We have not yet updated the sh404sef, autotweet or the JMailAlerts plugin to be compatible with Preachit 4.1. This will be done in the next few days so if you use these plugins be sure to hold off updating until they have been released and you can update them at the same time.

New Download Category

With this release we have added a new category to our download area. This is the 'archive' category. For the moment we have included Preachit 4.0.23 here for download should you require it. This is because Preachit 4.1 is not compatible with Joomla 2.5 and some users are still on this platform. We will no longer be developing Preachit 4.0 as our focus is now on Preachit 4.1.

A big thanks to everyone who has been supporting this project by purchasing subscriptions. We really hope that this new version opens up the possibilities and flexibility of the component.

BLOG COMMENTS POWERED BY DISQUS